M500 build log

Moderator: Mike Everman

PyroJoe
Posts: 1743
Joined: Wed Aug 29, 2007 5:44 pm
Antipspambot question: 125
Location: Texas

Re: M500 build log

Post by PyroJoe » Tue Jul 29, 2014 9:44 pm

Hope your doing well. Aloe vera works good if you can find it. Had trouble with my injectors moving also.
These big ones take some getting used to.

PyroJoe
Posts: 1743
Joined: Wed Aug 29, 2007 5:44 pm
Antipspambot question: 125
Location: Texas

Re: M500 build log

Post by PyroJoe » Thu Sep 11, 2014 9:58 pm

:shock: :shock: :shock: :shock:

https://www.youtube.com/watch?v=1R406q76sEA

How did you ever keep that back tire from melting?

Outstanding!

PyroJoe
Posts: 1743
Joined: Wed Aug 29, 2007 5:44 pm
Antipspambot question: 125
Location: Texas

Re: M500 build log

Post by PyroJoe » Thu Sep 11, 2014 10:01 pm

Holy gods of thunder, wow, wow, wow!

metiz
Posts: 1519
Joined: Fri Apr 21, 2006 6:34 pm
Antipspambot question: 125
Location: Netherlands

Re: M500 build log

Post by metiz » Fri Sep 12, 2014 11:51 am

Haha that engine is extremely similar to the M500, from the ejectors to the tailcone windings, but I had nothing to do with it. Cool as shit though!
Quantify the world.

PyroJoe
Posts: 1743
Joined: Wed Aug 29, 2007 5:44 pm
Antipspambot question: 125
Location: Texas

Re: M500 build log

Post by PyroJoe » Fri Sep 12, 2014 5:58 pm

Ha my mistake, yours was one of a few that has been built with the tail cone winding of that size. Must be a long lost brother of ours. :lol:

Hope your burns are mending well.

metiz
Posts: 1519
Joined: Fri Apr 21, 2006 6:34 pm
Antipspambot question: 125
Location: Netherlands

Re: M500 build log

Post by metiz » Fri Sep 12, 2014 7:15 pm

Hey Joe,

I send a message to the guy and apparently the engine was build with the M500 in mind. The tailpipe windings aren't to prevent it from sagging, but to prevent the tailpipe tearing appart because of vibrations. He ran his engine without the windings and that was exactly what happend.
https://lh6.googleusercontent.com/-7Aft ... G_0231.JPG

The burns have longs since healed btw. arm looks perfectly normal.
Last edited by metiz on Sat Sep 13, 2014 3:05 pm, edited 1 time in total.
Quantify the world.

PyroJoe
Posts: 1743
Joined: Wed Aug 29, 2007 5:44 pm
Antipspambot question: 125
Location: Texas

Re: M500 build log

Post by PyroJoe » Fri Sep 12, 2014 8:44 pm

Good to hear you are recovered, I was concerned for weeks.

Those are some big tears in the tailcone. If windings prevent that, we should use them more often!

ace_fedde
Posts: 421
Joined: Mon Feb 16, 2009 9:26 pm
Antipspambot question: 0
Location: The Netherlands

Re: M500 build log

Post by ace_fedde » Sun Oct 26, 2014 9:15 am

Your scepticism is fuel for my brain.

metiz
Posts: 1519
Joined: Fri Apr 21, 2006 6:34 pm
Antipspambot question: 125
Location: Netherlands

Re: M500 build log

Post by metiz » Sun Oct 26, 2014 5:13 pm

My ignition worked fine wouldn't you agree? Got some nasty burns to back me up on that. How's the pump?
Quantify the world.

Rocket Man
Posts: 144
Joined: Sat Sep 26, 2009 9:59 pm
Antipspambot question: 125

Re: M500 build log

Post by Rocket Man » Tue Oct 28, 2014 3:24 am

Does it run?

I would like to see a video.

ace_fedde
Posts: 421
Joined: Mon Feb 16, 2009 9:26 pm
Antipspambot question: 0
Location: The Netherlands

Re: M500 build log

Post by ace_fedde » Tue Oct 28, 2014 9:00 am

metiz wrote: My ignition worked fine wouldn't you agree? Got some nasty burns to back me up on that.
:lol: :lol: :lol:
metiz wrote: How's the pump?
That's the HP pump of my van that Metiz is asking about, folks. No luck yet, chasing a complete engine.
Your scepticism is fuel for my brain.

ace_fedde
Posts: 421
Joined: Mon Feb 16, 2009 9:26 pm
Antipspambot question: 0
Location: The Netherlands

Re: M500 build log

Post by ace_fedde » Tue Oct 28, 2014 9:02 am

Rocket Man wrote:Does it run?

I would like to see a video.
viewtopic.php?f=3&t=6560&start=135#p77563
Your scepticism is fuel for my brain.

Post Reply